Logos is taking forever to instal

JesseBassett

Follower of the way, the truth, and the life....
Angels Team
CF Senior Ambassador
Supporter
Apr 17, 2004
4,434
1,555
36
Inver Grove Heights, MN, USA
Visit site
✟385,877.00
Country
United States
Faith
Reformed
Marital Status
Single
Politics
US-Democrat
Hello all,
I am installing my full LOGOS 10 library on my pc right now. However it is only at 82% and I have very quick internet speeds. I also am plugged in via ethernet. Anyone have any ideas as to the slow download of the file?
 

Wookiee

Cool. Cool, cool, cool.
Jul 19, 2013
312
133
Australia
✟50,639.00
Country
Australia
Faith
Christian
There's a handful of factors at play:
- the size of the data (being LOGOS I assume it's like 50 TB)
- your download speed
- the upload speed of the server you're downloading from
- anything handling that data inbetween (largely your ISP, their provider and everything happening between other customers at that moment)
- the speed of the device the data is getting written to (mechanical disk vs SSD)
- the way the data is getting handled (if it's a straight file you're downloading and then installing, or if Logos uses its own installer to download and manage the data, it could be hitting some logic issues there)
- anything else going on with your local connection (other devices downloading large quantities of data, updates and other concurrent downloads on your own device, etc.)

I know absolutely nothing about Logos other than its name and what it's for, but I would guess your probilem is/was largely the first 4 points.
 
  • Agree
Reactions: linux.poet
Upvote 0